Back to overview
Downtime

We’re currently experiencing issues

Oct 20 at 11:30am EEST
Affected services
Health check
Orders Infrastructure

Resolved
Oct 20 at 02:00pm EEST

Services are operational. Please note, that due to this incident our support team is experiencing an increased workload, therefore response times might be prolonged. Thank you for your patience.

Created
Oct 20 at 11:30am EEST

Amazon Web Services (AWS) is currently experiencing a major outage that has taken down online services, including multiple services and platforms we use.

We’re actively monitoring status updates and will share new information as soon as it becomes available.